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IMAGE FOR WEB  
Image Formats ::  
 
We're going to look at the three common image formats used on the web: GIF, JPEG and 
PNG. You'll learn how these image formats work, and where to use each type of image in your 
web pages. 
 

> The GIF Image Format 

GIF stands for Graphics Interchange Format. It is probably the most common image 
format used on the Web. GIF's have the advantage of usually being very small in size, which 
makes them fast-loading. Unlike JPEG's, GIF's use lossless compression, which means they 
make the file size small without losing or blurring any of the image itself. 
GIF's also support transparency, which means that they can sit on top of a background image 
on your web page without having ugly rectangles around them. 
Another cool thing that GIF's can do is animation. You can make an animated GIF by drawing 
each frame of the animation in a graphics package that supports the animated GIF format, 
then export the animation to a single GIF file. When you include this file in your web page 
(with the IMG tag), your animation will be displayed on the page! 
The major disadvantage of GIF's is that they only support up to 256 colours (this is known as 
8-bit colour and is a type of indexed colour image). This means they're not good for 
photographs, or any other image that contains lots of different colours. 

>> Making Fast-Loading GIF's 

It's worthwhile making your GIF file sizes as small as possible, so that your web pages load 
quickly. People will get very bored otherwise, and probably go to another web site! 
Most graphics programs let you control various settings when making a GIF image, such as 
palette size (number of colours in the image) and dithering. Generally, speaking, use the 
smallest palette size you can. Usually 32 colour palette produce acceptable results, although 
for low-colour images you can often get away with 16. Images with lots of colours will of 
course need a bigger palette - say, 128, or even 256 colours. 
 

  
8-colour GIF  
(1292 bytes) 

64-colour GIF  
(2940 bytes) 

> The JPEG Image Format 

JPEG stands for Joint Photographic Experts Group, a bunch of boffins who invented this 
format to display full-colour photographic images in a portable format with a small file size. 
Like GIF images, they are also very common on the Web. Their main advantage over GIF's is 
that they can display true-colour images (up to 16 million colours), which makes them much 
better for images such as photographs and illustrations with large numbers of colours. 
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The main disadvantage of the JPEG format is that it is lossy. This means that you lose some of 
the detail of your image when you convert it to JPEG format. Boundaries between blocks of 
colour may appear more blurry, and areas with lots of detail will lose their sharpness. On the 
other hand, JPEG's do preserve all of the colour information in the image, which of course is 
great for high-colour images such as photographs. 
JPEG's also can't do transparency or animation - in these cases, you'll have to use the GIF 
format (or PNG format for transparency). 

>> Making Fast-Loading JPEG's 

As with GIF's, it pays to make your JPEGs as small as possible (in terms of bytes), so that 
your web sites load quickly. The main control over file size with JPEG's is called quality, and 
usually varies from 0 to 100%, where 0% is low quality (but smallest file size), and 100 is 
highest quality (but largest file size). 0% quality JPEG's usually look noticeably blurred when 
compared to the original. 100% quality JPEG's are often indistinguishable from the original: 
 

  
 Low-quality JPEG (4089 bytes)  High-quality JPEG (17465 bytes) 

 
> The PNG Image Format 

PNG is a relatively new invention. It stands for Portable Network Graphics. It was designed 
to be an alternative to the GIF file format, but without the licensing issues that are involved in 
the GIF compression method.  
There are two types of PNG: PNG-8 format, which holds 8 bits of colour information 
(comparable to GIF), and PNG-24 format, which holds 24 bits of colour (comparable to JPEG). 
PNG-8 often compresses images even better than GIF, resulting in smaller file sizes. On the 
other hand, PNG-24 is often less effective than JPEG's at compressing true-colour images such 
as photos, resulting in larger file sizes than the equivalent quality JPEG's. However, unlike 
JPEG, PNG-24 is lossless, meaning that all of the original image's information is preserved. 
PNG also supports transparency like GIF, but can have varying degrees of transparency for 
each pixel, whereas GIF's can only have transparency turned on or off for each pixel. This 
means that whereas transparent GIF's often have jagged edges when placed on complex or ill-
matching backgrounds, transparent PNG's will have nice smooth edges. 
Note that unlike GIF, PNG-8 does not support animation. 
One important point about PNG: Earlier browsers don't recognise them. If you want 
to ensure your website is viewable by everybody, use GIF's or JPEG's instead. 
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16-colour PNG-8  
(6481 bytes) 

Full-colour PNG-24  
(34377 bytes) 

 

Summary of Image Formats:: 
This table summarises the key differences between the GIF, JPEG and PNG image formats.  
 

GIF JPEG PNG-8 PNG-24 

Better for clipart and drawn 
graphics with few colours, 
or large blocks of colour 

Better for 
photographs with 
lots of colours or fine 
colour detail 

Better for clipart and drawn 
graphics with few colours, 
or large blocks of colour 

Better for photographs 
with lots of colours or 
fine colour detail 

Can only have up to 256 
colours 

Can have up to 16 
million colours 

Can only have up to 256 
colours 

Can have up to 16 
million colours 

Images are "lossless" - they 
contain the same amount of 
information as the original 
(but with only 256 colours) 

Images are "lossy" - 
they contain less 
information than the 
original 

Images are "lossless" - they 
contain the same amount of 
information as the original 
(but with only 256 colours) 

Images are "lossless" - 
they contain the same 
amount of information 
as the original 

Can be animated Cannot be animated Cannot be animated Cannot be animated 

Can have transparent areas 
Cannot have 
transparent areas 

Can have transparent areas
Can have transparent 
areas 

 
On the whole, GIFs are better for the Web, as Web graphics tend to be small, have a small 
amount of colours, and sometimes need fancy stuff like animation or transparency. However, 
JPEGs are really handy when you have a very complex or large image (such as a photo), 
and/or you want a full colour image. PNG-8 can often produce smaller file sizes than GIF, and 
both types of PNG are lossless. 
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USING IMAGE EDITORS FOR WEB  
 
USING PHOTOSHOP :: PHOTOSHOP�S LOGIC/STRUCTURE :: PRINCIPLES  
 
Adobe Photoshop is the basic, the primary and the  most important tool in Digital Image 
Editing.  
You can�t imagine, as a Digital Image Designer, a life without Photoshop; Photoshop is, 
actually, a Digital Fine Art Studio: you have there an easel, pens, pencils, brushes, airbrushes, 
erasers, you can choose between watercolours and oilcolours, between pencil and charcoal 
and, on top of all, you have Sp Fx, - Special Effects.  
 
One of the most important Photoshop�s functional principles is constituted by the fact that 
Photoshop thinks an image and edit it in/on LAYERS.  

LAYERS 
 
> What layers are: 
 
The easiest way to explain layers is with an example. The following image shows a Photoshop 
document containing two layers, a background layer and a text layer: 

 
 
Each layer can be manipulated, drawn on, and moved around independently of any other 
layer. Imagine that each layer is actually a physical sheet of clear plastic, with the graphic 
imprinted on the plastic: 
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> Creating a Layered Document 
 
Layers are controlled through the Layers palette in Photoshop. In this palette, you can see 
each layer along with a thumbnail showing the contents of the layer. 

At the bottom of the palette you'll see a little New icon. Click on this icon to add a layer to 
your document: 
 

 
You can now draw on your new layer, and it will not affect the layers below it, just as if it was 
a separate sheet of plastic on top of the image. Cool, eh? :) 
Before working on a layer, make sure you click on the layer you want to work with in the 
Layers palette first, so that it becomes active. The currently active layer is shown highlighted 
in blue above (Layer 1). 

> Naming Layers 

Layer 1 isn't a very memorable name, but luckily you can change the name of your new layer 
easily! Double-click on the Layer 1 layer in the Layers palette and you will see the Layer 
Options dialog appear. You can then enter a new name for your layer in the Name: box, and 
click OK to rename the layer. 

> Moving Layers Around 

Just like a real sheet of plastic, you can "slide" your layer around on the page. To do this, 
select the Move tool (the arrow with the crosshair next to it, at the top of the Tools palette), 
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or press the V key. Select the layer you want to work with in the Layers, then you can move 
the layer around by clicking with the mouse in the document window and dragging: 
 

 
 
A nice shortcut is to just hold down the Control key and drag to move your layer around. This 
has the advantage that you don't have to switch to the Move tool and back again - the 
current tool remains active while you move the layer. 
You can also move layers above or below other layers in the document. To do this, click on the 
layer in the Layers palette and drag it so that it's where you want it to be: 
 

 
 
Another quick shortcut here is to use the Control + [ key and Control + ] key to move the 
current layer down and up respectively. 

> Showing and Hiding Layers 

Often it's useful to be able to hide a layer so you can work on the layers underneath it, or hide 
all other layers so you can concentrate on the current layer. You can do all this using the little 
eye icons next to each layer in the Layers palette: 
 

 
 
To hide a layer, click once on the eye icon. The eye will disappear and the layer will become 
invisible. 
To show the layer again, click again on the eye icon. The layer will reappear. 
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To hide all layers except one, Alt+click on the eye icon for the layer you want to keep. 
Alt+click on the eye again to reveal all the layers. 
 

> Copying Layers 
 
You'll often want to duplicate an existing layer so that you can work on a copy of it. To make a 
copy of a layer, either drag the layer in the Layers palette to the New icon at the bottom of 
the palette, or select the layer and then select Layer > Duplicate Layer... (this method allows 
you to name the new layer too!). 

> Deleting Layers 

If you get carried away with your layers(!) and you want to delete one, find the layer in the 
Layers palette and drag it down to the little trash can icon. Or select Delete Layer from 
the Layer menu. 
 

> Preserving Layer Transparency 

Often, not every part of a layer will be covered with graphics. For example, with our example, 
the text layer only has pixels for the word "Stonehenge" at the bottom; the rest of the layer is 
empty. These empty pixels are transparent. 
If you check the Lock transparent pixels  (  Preserve Transparency for Photoshop 5 ) box 
in the Layers palette, all the transparent pixels in the currently selected layer will remain 
transparent, even if you try to paint over them or fill them. 
 

 
 
This is often very useful, as it allows you to work with just the stuff in the layer, rather than 
the whole layer. For example, here we've drawn a green like with the Paintbrush tool right 
through the words "Operating Group Directories", both with and without Preserve 
Transparency checked:  
 

 
Without Preserve Transparency Checked 
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With Preserve Transparency Checked 
 

> Changing the Opacity of Layers 
 
You can change how opaque a layer is, in other words, how much of the underlying image 
shows through the layer, with the Opacity option in the Layers palette: 
 

 
 
You can enter a value by clicking on the number in the box and entering a new number, or by 
clicking on the arrow next to the number and then dragging the slider that pops up. You can 
also use the keyboard number keys 1, 2, 3, etc to quickly enter values of 10%, 20%, 30% 
etc, but this only works if you're using a tool that doesn't have an Opacity option (for example 
the Marquee tool). This option allows you to blend layers together subtly, with the topmost 
layers being slightly transparent, allowing the bottom layers to show through. For example: 
 

 
�Operating Group Directories� layer with 54% opacity 

> Blending Options 

If you click the "Normal" drop-down box in the Layers palette, you will see a long list of 
blending modes that you can choose for the current layer:  
 



N&M Design  Application Document 
 Doc. No.    Rev. No. 1 
 Date:  10/18/2002 Page 10 of 21  
 

© N&M Design, 2002 
 

 
 
The best way to understand these modes is just to play around with them and see what they 
do! Some of them, such as Overlay and Soft Light, are good for creating realistic light 
effects, while others such as Difference and Exclusion produce some quite wacky effects! 
 

SELECTION :: SELECTING 
 
We�ll present you some ways to select areas of your images using the variety of selection tools 
available in Photoshop. First we'll talk about why selecting part of an image is so useful, and 
then we'll examine the various selection methods in Photoshop: the Marquee tools; the Lasso 
tools; the Magic Wand tool; the Color Range tool; and the Quick Mask mode. Finally, we'll look 
at ways to modify and fine-tune your selections. 

> Why use selections? 

Selections are a great way to work on parts of your image independently, rather than 
manipulating the image as a whole. 
Once you've selected a part of an image (e.g. a person's head or other object), you can then 
manipulate this object separately from the rest of the image. This means you can cut the 
object out; add drop shadows; adjust the brightness/contrast; warp it; apply effects and filters 
easily - in fact, anything you like! 
Now let's look at the different selection tools in Photoshop, starting with the Marquee tools. 
 

> The Marquee tools : 

The simplest selection tools to use are the marquee tools. These include the Rectangular, 
Elliptical, Single Row and Single Column marquee tools. Activate the tools by clicking and 
holding the mouse button on the top-left tool in the Tools Palette: 
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Click on the tool you would like to use. The Rectangular Marquee tool lets you select a 
square or rectangular area; the Elliptical Marquee tool selects a circular or elliptical area; 
and the Single Row and Single Column tools select a single line of pixels either horizontally 
or vertically. 
To use one of the Marquee tools, click and drag out the selection with the mouse in your 
image: 
 
> Creating a selection with the Rectangular Marquee Tool 
 

 
By holding down the Shift key while dragging, you can constrain the selection to a square (for 
the Rectangular Marquee tool) or a circle (for the Elliptical Marquee tool): 
 
> Creating a circular selection with the Elliptical Marquee Tool 
 

 
 
  
 
Also, by holding down the Alt key while dragging, you can drag from the centre of the 
selection rather than from the edge - this is great for positioning circular selections precisely! 
Try it out to see what we mean. 
 
> The Lasso tools 
 
The lasso tools are great for seleting well-defined, irregularly-shaped areas. For example, they 
work well on strong foreground features of an image, such as a person's head. 
To use the Lasso selection tools, click and hold the mouse on the Lasso tool icon in the Tools 
Palette: 
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Click on the tool you'd like to use. The best way to learn about these tools is to try them out, 
but here are some pointers for you: 

> Lasso tool 

The regular Lasso Tool lets you select freehand areas by clicking and dragging with the 
mouse - when you release the mouse the "loop" is closed, completing the selection. This tool 
is great for quickly selecting a rough area. 
 

 
 
> Polygonal lasso tool 
 
The Polygonal Lasso Tool lets you create selections based on straight lines (or segments). 
This allows you more precise control when selecting using the mouse. Click with the mouse in 
your image to add the first fastening point, then move the mouse and click again to create a 
new fastening point with a segment in between. Continue in this way until you're done, then 
close the selection border by moving the mouse over the first point and clicking (double-
clicking with the mouse will also close the selection automatically).  
 

 

> Magnetic lasso tool 

The Magnetic Lasso Tool is similar to the Polygonal tool, but it tries to add fastening points 
automatically based on the edge of the area you're selecting. For this reason, the magnetic 
lasso tool works best when selecting areas that contrast well with their surroundings. As with 
the Polygonal tool, you click to start it off. You can also add your own points by clicking. Finish 
the selection by moving the mouse over the first point and clicking, or just double-clicking. 
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The magnetic lasso tool's Options let you control the tool's sensitivity: 
 

 
 
Width controls the range of pixels around the mouse pointer within which the tool looks for 
the edge of the object you're tracing. If your object has well-defined edges you can set a high 
width value and trace the object quickly and roughly. For more blurred edges, reduce the 
width and trace more precisely. 
Edge Contrast specifies the tool's sensitivity to the edge of the object you're selecting. A high 
Edge Contrast will only detect edges that contrast strongly with the rest of the image, 
whereas a low Edge Contrast will detect softer edges. 
The Frequency option controls how often the magnetic lasso tool will automatically place 
fastening points. A higher Frequency value will place more fastening points as you trace 
round the object. 

> Lasso Tips 

If you place a fastening point incorrectly with the polygonal or magnetic lasso tools, press the 
Delete key on the keyboard to "undo" the point. You can keep pressing Delete all the way 
back to the first fastening point if necessary. 
As well as the automatic points added by the magnetic lasso, you can add your own manual 
fastening points by clicking with the mouse. 
You can temporarily turn the regular lasso tool into the polygonal lasso tool by holding down 
Alt (Windows) or Option (Mac), then releasing the mouse button, then clicking where you 
want the end of the straight line segment to be. To revert to the regular lasso, release the 
Alt/Option key while the mouse button is held down. 
Likewise, you can turn the polygonal and magnetic lasso tools into the regular lasso tool by 
holding down Alt/Option and dragging with the mouse. 
The magnetic lasso tool can be turned into the polygonal lasso tool by holding down 
Alt/Option and clicking with the mouse where you want the straight line segments to end. 
As well as double-clicking to close polygonal and magnetic selections, you can also hold down 
the Control key and click. 

> The Magic Wand tool 

The Magic Wand tool is a great way to select irregular-shaped objects that are just one colour 
(for example, a red rose, or a person's hand). To activate the tool, click on the Magic Wand 
icon in the Tools palette: 
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To use the tool, click inside the object you would like to select. You'll see that the tool selects 
all the pixels that are similar in colour to the pixel you clicked on: 
 

 
 
Often, your object will contain a couple of colours; in the above example, the flower has a 
green centre as well as the red petals. To select the centre as well, we simply hold down the 
Shift key and click in the centre to add to our selection (see Adding and Subtracting further 
down the page): 
 

 

> Tolerance option 

The Tolerance setting lets you to control the sensitivity of the Magic Wand tool: 
 

 
 
If the Tolerance value is high, a wider range of colours will be selected. For example, if you 
click on a red pixel when the Tolerance is set very high, the Magic Wand tool might also 
select pixels that are pink and orange. If you set the Tolerance to a lower value, then only 
pixels that are very similar to the shade of red you clicked on will be selected. Experiment with 
different Tolerance values so that most or all of your object gets selected, without selecting 
the background as well. 
Contiguous option 
If you check the Contiguous box next to Tolerance, then only adjacent areas of the same 
colour will be selected. If you deselect Contiguous, all pixels of the same colour will be 
selected. 
 
 
> The Color Range tool 
 
The Color Range tool is great for selecting particular colours in your image - for example, all 
the reds, or all the greens. You can then work on these specific colours - turning them from 
green to red, for example, or removing particular colours from the image. 
This tool doesn't work well for selecting particular areas of your image (such as a foreground 
object), as it has a tendency to only partially select pixels, and often selects unwanted parts of 
your image that are a similar colour. But it's great for selecting colours to work on! 
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To use the tool, choose the Select > Color Range menu option. You'll see the Color Range 
dialog appear: 
 

 
 
The most flexible way to use the tool is in the Sampled Colors mode (choose Sampled 
Colors from the Select: drop-down box). Click with the mouse in the document window on an 
area of your image that contains the colour you want to select. You'll then see this colour 
range turn white in the preview inside the Color Range dialog. This means that this range has 
been selected. 
(Tip: You can also click in the preview window to choose the colour to use.) 
 
> Changing the selection 
 
To increase the degree to which colours in the colour range are selected, increase the 
Fuzziness slider. You'll see increasing areas of the preview image turning white as the degree 
to which each pixel is selected increases. Slide the slider to the left to decrease the intensity of 
the selection. 
You can add to the range of selected colours by holding down the Shift key and clicking on 
new areas of colour in your image. Alternatively, you can click on the eyedropper icon with the 
little plus sign in the Color Range dialog. 
Likewise, you can subtract colours by holding down the Alt/Option key and clicking in the 
image, or selecting the eyedropper icon with the minus sign then clicking in the image. 

> Preview options 

You can click on the Image radio button to preview the entire image in the dialog (useful if 
you can't see all of the image in the main window). Click the Selection radio button to revert 
to the normal preview mode. 
You can also preview the selected areas in the main document window using the Selection 
Preview drop-down box. You can choose from the following options: 
Grayscale shows how the selection will appear if converted to a channel. 
Black Matte will show the selected areas in colour over a black matte background. 
White Matte will show the selected areas in colour over a white matte background. 
Quick Mask shows how the selection would look in Quick Mask mode, using the current 
Quick Mask settings (see below for info on the Quick Mask mode). 

> Color Range presets 
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The Select: drop-down box allows you to choose various preset colour ranges, such as all 
Reds, Blues or Greens in the image. You can also select just the Highlights, Midtones or 
Shadows. 
Out of Gamut will select all the colours in the image that are out-of-gamut (i.e. cannot be 
printed). 
 

> An example 

In this example, we want to select all the green leaves in the image so that we can change 
their colour. To do this, we use the Color Range tool in Sampled Colors mode, then 
Shift+click on a couple of leaf areas to select a broad range of greens: 
 

 
 
 
We then click OK to create the selection, and use Image > Adjust > Hue/Saturation to 
change the leaves from green to brown, without affecting the rest of the image: 
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> The Quick Mask mode 

Photoshop's Quick Mask mode is a really versatile way of selecting stuff. Instead of creating 
marquees as you do with the other tools, you can actually "paint" the selection using any of 
Photoshop's painting tools. You can even use the other selection tools on the Quick Mask, as if 
it was a regular image! This makes the Quick Mask mode a very powerful feature of 
Photoshop. 
To activate Quick Mask mode, click on the Edit in Quick Mask mode button in the Tools 
palette, or press the Q key: 
 

 
 
You may like to select something with a regular selection tool (e.g. the Marquee tool) before 
entering Quick Mask mode, so that you can clearly see what's selected and what isn't: 
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You can see that the un-selected areas of the image are covered with the red mask when in 
Quick Mask mode. 
You can now "paint" on the mask using any of the painting tools (Pencil, Paintbrush, Airbrush, 
etc), and use the Eraser tool to erase areas of the mask (in other words, to select more 
pixels). You can even use other tools such as the Fill and Smudge tools. 
 

 
 
When you're ready, you can click the Edit in Standard Mode button to switch back to the 
regular marquee selection (or press the Q key again): 
 

       
 
 

> Modifying Selections 

Once you've made your basic selection using the above tools, there are a lot of things you can 
do to play around with it. In this section we'll look at Feathering, Anti-aliasing, Adding and 
Subtracting, Bordering, Smoothing, and Expanding and Contracting. 
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> Feathering 
 

Many of the selection tools include a Feather option: 
 

 
 
Feathering blurs the edges of the selection so that the selection partially blends with the non-
selected area. Note that feathering causes some loss of detail in your selection! 
Feathering is useful for "softly" selecting an area of an image. Then, when you manipulate the 
selection, the boundary between the affected areas and the non-effected areas will not be a 
harsh line, but the effect will gradually fade towards the edge of the selection. 
 

 
Original selection 

 
Selection copied and pasted with 0% 

feathering 

 
Selection copied and pasted with 10% 

feathering 
 
To feather the selection, enter a value greater than zero in the Feather option shown above 
before you create your selection. Alternatively, to feather a selection after it's been created, 
use the Select > Feather... menu option. 
 

> Anti-aliasing 
 
Anti-aliasing is the process of reducing the jagged "staircase effect" caused when a line or 
curve of pixels of one colour meets a line of pixels of another, contrasting colour. Anti-aliasing 
is achieved by averaging the colours of the edge pixels of a selection between the selected 
area's colour and the background's colour. 

 

 
Circular selection with no anti-aliasing 

 
Circular selection with anti-aliasing 

 
Note that, unlike feathering, only the edge pixels are changed. Anti-aliasing does not blur 
outwards from the edge like feathering does. 
To use anti-aliasing when making a selection, check the Anti-aliased option before creating 
your selection: 
 

            
 
Note that you must enable anti-aliasing before you draw your selection, as there is no way to 
add anti-aliasing afterwards! 
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> Adding and Subtracting 

You can modify the shape of your selection by: 
 > Adding new areas to the selection 
 > Removing (subtracting) areas from the selection 
 > Creating intersections with the selection and a new area 
 
> Adding 
 

 
To add to an existing selection, hold down the Shift key while creating your new selection, or 
click on the Add to selection button: 

> Subtracting 

To subtract from an existing selection, hold down the Alt/Option key while creating your new 
selection, or click on the Subtract from selection button: 
 

 

> Intersecting 

To intersect with an existing selection, hold down the Shift and Alt/Option keys while 
creating your new selection, or click on the Intersect with selection button: 
 

 

> Border 

You can turn an existing selection into a border selection. A border selection selects just the 
edge of the original selection. To turn a selection into a border, pick the menu option Select > 
Modify > Border. In the Width box, enter how wide you would like the border to be (in 
pixels). 
 

Original selection Bordered selection 

> Smoothing 

Smoothing rounds off the sharp edges of a selection by averaging the selected and non-
selected pixels over a specified sample radius. This is great for creating smooth curvy 
selections, or for filling in bits that were missed out when using the Color Range tool. 
To use smoothing, choose Select > Modify > Smooth. Enter a value for Sample Radius - 
the higher the value, the more pronounced will be the smoothing effect. 
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Original selection 

 
Smoothed selection

> Expanding and Contracting 

You can change the size of your selection after you've created it. To make the selection 
bigger, choose Select > Modify > Expand and enter the number of pixels you'd like to 
expand the selection by. 
Similarly, to make the selection smaller, choose Select > Modify > Contract and enter the 
number of pixels to contract the selection by. 
 


